Avec cette nouvelle année, PHP le langage de programmation de WordPress ne sera plus supporté dans sa version 5, version utilisée aujourd’hui sur une majorité d’hébergements. Et qui dit fin du support, dit fin des mises à jour de sécurité sur cette version synonyme donc de faille de sécurité pour vos sites. Un grand travail de mise à jour vers la version 7.2 de Php va donc devoir être mené cette année.   

Your PHP version is too old: PHP 5 ne sera plus supporté à partir du 31 décembre 2018 !

PHP est le langage de programmation incontournable le plus utilisé à travers le Monde pour le développement de pages Web dynamiques via un serveur http. La version 5 de ce langage ne sera plus supportée à partir du 31 décembre 2018. Il n’y aura donc plus de mises à jour de sécurité pour protéger la version 5 du langage PHP contre de futures failles de sécurité. Voici un exemple de mise à jour de sécurité de PHP 7. Toutes les pages Web développées avec une version de PHP 5 constitueront à l’avenir autant de failles potentielles de sécurité.  

 

En résumé : cette information concerne directement tous les utilisateurs de wordpress, cms développé avec PHP.

PHP 7.2 « recommended but not required » sur WordPress 5.x

WordPress est un cms développé justement à l’aide de PHP! La dernière version de WordPress au moment où nous écrivons cet article est la version 5.0.1. Les préconisations techniques de cette version recommandent d’utiliser une version de PHP 7.2 ou supérieure.

C’est donc l’occasion de tout remettre à plat avec cette nouvelle version et d’en profiter pour mettre à jour la version de php sur son hébergement. Attention d’ailleurs, il serait possible de faire fonctionner wordpress (version 5 comprise) sur une version PHP 5.2.4 source displaywp

 

En résumé : Si vous étiez jusqu’à présent plutôt en retard dans la maintenance de votre site WordPress, ce sera l’occasion de tout remettre à plat en 2019 en migrant vers la version 5 de wordpress et en mettant à jour son hébergement vers la version 7 de PHP.

Du côté de votre hébergement proscrire PHP 5.6 !

ZDNET estime que 32% des sites web continueront à utiliser une version une version non supportée de PHP en début d’année 2019. Bon nombre des hébergements en effet utilisent encore PHP 5.6. 

Quelle que soit la solution d’hébergement utilisée il va falloir mettre à jour PHP vers la version 7.2. Cette opération est en général simple sur les hébergements mutualisés récents. Elle peut s’avérer plus difficile sur des hébergements hors d’age ou sur des serveurs dédiés ou des VPS. Quoi qu’il en soit il vous faudra vous renseigner auprès de votre hébergeur.  

 

En résumé : vérifiez la version PHP de votre hébergement et faites en sorte de migrer rapidement vers PHP 7.

Vous souhaitez de l’aide pour mettre à jour la version PHP de votre hébergement WordPress ?

Panier Produit supprimé. Annuler
  • Votre panier est actuellement vide.